#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/(?!direct-payments-survey)(directpayment|direct-payment).*"
Local $sString = "/direct-payments-servey" & @CRLF & _
"/direct-payments-urvey" & @CRLF & _
"/directpayment-survery/" & @CRLF & _
"/directpaymentsurvey" & @CRLF & _
"/directpaymentssurvey" & @CRLF & _
"/direct-payments-survey/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")