const regex = /^\/(?!direct-payments-survey)(directpayment|direct-payment).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/(?!direct-payments-survey)(directpayment|direct-payment).*', 'gm')
const str = `/direct-payments-servey
/direct-payments-urvey
/directpayment-survery/
/directpaymentsurvey
/directpaymentssurvey
/direct-payments-survey/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}