re = /^\/(?!direct-payments-survey)(directpayment|direct-payment).*/m
str = '/direct-payments-servey
/direct-payments-urvey
/directpayment-survery/
/directpaymentsurvey
/directpaymentssurvey
/direct-payments-survey/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end