using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)Subject:\s*\K.*?(?=\RAttachements:|$)";
string input = @"From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text
Attachements: welcome.jpg, foo.pdf
From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}