$re = '/(?s)Subject:\s*\K.*?(?=\RAttachements:|$)/';
$str = 'From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text
Attachements: welcome.jpg, foo.pdf
From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);