re = /(?s)Subject:\s*\K.*?(?=\RAttachements:|$)/
str = 'From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text
Attachements: welcome.jpg, foo.pdf
From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end