re = /href="(.*?)" rel/
str = '<li class="b-index-nav__item"><a href="/work/" class="b-index-nav__link">Портфолио</a></li><li class="b-index-nav__item"><a href="/jobs/" class="b-index-nav__link">Вакансии</a></li><li class="b-index-nav__item"><a href="/contact/" rel="nofollow" class="b-index-nav__link">Контакты</a></li>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end