// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href="(.*?)" rel"#).unwrap();
let string = "<li class=\"b-index-nav__item\"><a href=\"/work/\" class=\"b-index-nav__link\">Портфолио</a></li><li class=\"b-index-nav__item\"><a href=\"/jobs/\" class=\"b-index-nav__link\">Вакансии</a></li><li class=\"b-index-nav__item\"><a href=\"/contact/\" rel=\"nofollow\" class=\"b-index-nav__link\">Контакты</a></li>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}