import Foundation
let pattern = #"href="(.*?)" rel"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<li class="b-index-nav__item"><a href="/work/" class="b-index-nav__link">Портфолио</a></li><li class="b-index-nav__item"><a href="/jobs/" class="b-index-nav__link">Вакансии</a></li><li class="b-index-nav__item"><a href="/contact/" rel="nofollow" class="b-index-nav__link">Контакты</a></li>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)