import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ActiveCampaign\\/email";
final String string = "activecampaign/email/dp philippines newsletter 10apr2019\n"
+ "ActiveCampaign/email/The Cube Pattaya TH-EN ALL 22AUG19/Luxury Condo Development in Pattaya, Thailand\n"
+ "ActiveCampaign/email/Samui Beachfront Villas TH-EN Group TH-EN MAY19 (Tide Samui)/Beachfront Villas in Koh Samui with Private Pool";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}