const regex = /^ActiveCampaign\/email/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ActiveCampaign\\\/email', 'gm')
const str = `activecampaign/email/dp philippines newsletter 10apr2019
ActiveCampaign/email/The Cube Pattaya TH-EN ALL 22AUG19/Luxury Condo Development in Pattaya, Thailand
ActiveCampaign/email/Samui Beachfront Villas TH-EN Group TH-EN MAY19 (Tide Samui)/Beachfront Villas in Koh Samui with Private Pool`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}