const regex = /(?m)^(?!Subtotal.*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)^(?!Subtotal.*).*', 'gm')
const str = `Subtotal test test £20.00
Value £10.00
Subtotal test 2 £4.00
Value2 £30.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}