$re = '/(?m)^(?!Subtotal.*).*/m';
$str = 'Subtotal test test £20.00
Value £10.00
Subtotal test 2 £4.00
Value2 £30.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);