re = /(?m)^(?!Subtotal.*).*/m
str = 'Subtotal test test £20.00
Value £10.00
Subtotal test 2 £4.00
Value2 £30.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end