using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([一-龟]+:)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\n";
string substitution = @"$1$2$3$4$5$6$7\n";
string input = @" 位: {
default: '左',
type: String,
},
高: {
default: '',
type: [String, Number],
},
宽: {
default: '',
type: [String, Number],
},
驼高: {
default: '',
type: String,
},
骆高: {
default: '',
type: String,
},
样: {
default: '工 gong',
type: String,
},
料: {
default: () => {
return []
},
type: Array,
},
啥: {
defaule: () => {
return {}
},
type: Object,
},";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}