// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([一-龟]+:)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\s*([^\n]*?)\n\s*([^\n]*?)\n").unwrap();
let string = " 位: {
default: '左',
type: String,
},
高: {
default: '',
type: [String, Number],
},
宽: {
default: '',
type: [String, Number],
},
驼高: {
default: '',
type: String,
},
骆高: {
default: '',
type: String,
},
样: {
default: '工 gong',
type: String,
},
料: {
default: () => {
return []
},
type: Array,
},
啥: {
defaule: () => {
return {}
},
type: Object,
},";
let substitution = "$1$2$3$4$5$6$7\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}