package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?\:\/\/[\w.]+`)
var str = `https://site.ru
http://site.ru
http://site.xyz/bla
https://site.com/blabla/test
https://en.site.com/blabla/test
site.ru/blabla/test/test2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}