$re = '/^https?\:\/\/[\w.]+/m';
$str = 'https://site.ru
http://site.ru
http://site.xyz/bla
https://site.com/blabla/test
https://en.site.com/blabla/test
site.ru/blabla/test/test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);