re = /^https?\:\/\/[\w.]+/m
str = 'https://site.ru
http://site.ru
http://site.xyz/bla
https://site.com/blabla/test
https://en.site.com/blabla/test
site.ru/blabla/test/test2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end