#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Mozilla/5\.0 (\(Linux; Android 6.0.1; Nexus 5X Build/MMB29P\) )?(AppleWebKit/[0-9]+\.[0-9]+ \(KHTML, like Gecko[\);] )?(Chrome/[0-9]{2,3}\.[0-9]+\.[0-9]+\.[0-9]+ Mobile Safari/[0-9]+\.[0-9]+ )?\(?compatible; )?Googlebot((-Image|-Video)?/[0-9]\.[0-9]|-News)(;? \(?\+http://www\.google\.com/bot\.html\)( Chrome/[0-9]{2,3}\.[0-9]+\.[0-9]+\.[0-9]+ Safari/[0-9]+\.[0-9]+)?)?$" & @CRLF & _
""
Local $sString = "Valid GoogleBots:" & @CRLF & _
"" & @CRLF & _
"Googlebot-Image/1.0" & @CRLF & _
"" & @CRLF & _
"Googlebot-News" & @CRLF & _
"" & @CRLF & _
"Googlebot-Video/1.0" & @CRLF & _
"" & @CRLF & _
"Googlebot/2.1 (+http://www.google.com/bot.html)" & @CRLF & _
"" & @CRLF & _
"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" & @CRLF & _
"" & @CRLF & _
"Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; Googlebot/2.1; +http://www.google.com/bot.html) Chrome/80.20.123.1243 Safari/537.36" & @CRLF & _
"" & @CRLF & _
"Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5X Build/MMB29P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2213.123 Mobile Safari/537.36 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Invalid GoogleBots:" & @CRLF & _
"" & @CRLF & _
"Googlebot" & @CRLF & _
"" & @CRLF & _
"googlebot/2.1" & @CRLF & _
"" & @CRLF & _
"Googlebot/2.1 (+http://www.google.com/bot.html) +IKAUE" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")