# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^(Mozilla/5\.0 (\(Linux; Android 6.0.1; Nexus 5X Build/MMB29P\) )?(AppleWebKit/[0-9]+\.[0-9]+ \(KHTML, like Gecko[\);] )?(Chrome/[0-9]{2,3}\.[0-9]+\.[0-9]+\.[0-9]+ Mobile Safari/[0-9]+\.[0-9]+ )?\(?compatible; )?Googlebot((-Image|-Video)?/[0-9]\.[0-9]|-News)(;? \(?\+http://www\.google\.com/bot\.html\)( Chrome/[0-9]{2,3}\.[0-9]+\.[0-9]+\.[0-9]+ Safari/[0-9]+\.[0-9]+)?)?$\n")
test_str = ("Valid GoogleBots:\n\n"
"Googlebot-Image/1.0\n\n"
"Googlebot-News\n\n"
"Googlebot-Video/1.0\n\n"
"Googlebot/2.1 (+http://www.google.com/bot.html)\n\n"
"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\n\n"
"Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; Googlebot/2.1; +http://www.google.com/bot.html) Chrome/80.20.123.1243 Safari/537.36\n\n"
"Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5X Build/MMB29P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2213.123 Mobile Safari/537.36 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\n\n\n"
"Invalid GoogleBots:\n\n"
"Googlebot\n\n"
"googlebot/2.1\n\n"
"Googlebot/2.1 (+http://www.google.com/bot.html) +IKAUE\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.