use strict;
my $str = 'Valid GoogleBots:
Googlebot-Image/1.0
Googlebot-News
Googlebot-Video/1.0
Googlebot/2.1 (+http://www.google.com/bot.html)
Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; Googlebot/2.1; +http://www.google.com/bot.html) Chrome/80.20.123.1243 Safari/537.36
Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5X Build/MMB29P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2213.123 Mobile Safari/537.36 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)
Invalid GoogleBots:
Googlebot
googlebot/2.1
Googlebot/2.1 (+http://www.google.com/bot.html) +IKAUE
';
my $regex = qr/^(Mozilla/5\.0 (\(Linux; Android 6.0.1; Nexus 5X Build/MMB29P\) )?(AppleWebKit/[0-9]+\.[0-9]+ \(KHTML, like Gecko[\);] )?(Chrome/[0-9]{2,3}\.[0-9]+\.[0-9]+\.[0-9]+ Mobile Safari/[0-9]+\.[0-9]+ )?\(?compatible; )?Googlebot((-Image|-Video)?/[0-9]\.[0-9]|-News)(;? \(?\+http://www\.google\.com/bot\.html\)( Chrome/[0-9]{2,3}\.[0-9]+\.[0-9]+\.[0-9]+ Safari/[0-9]+\.[0-9]+)?)?$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}