$re = '/http(.*?).(jpg|png|gif|webp|jpeg)/mi';
$str = 'https://gitee.com/artiely/Figure-bed/raw/master/20220123084210.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);