// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)http(.*?).(jpg|png|gif|webp|jpeg)").unwrap();
let string = "https://gitee.com/artiely/Figure-bed/raw/master/20220123084210.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}