using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]{3,40}(?:\s[A-Z])?\s[a-zA-Z]{3,40}$";
string input = @"John Doe
John M Doe
John Mr Doe
John m Doe";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}