package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]{3,40}(?:\s[A-Z])?\s[a-zA-Z]{3,40}$`)
var str = `John Doe
John M Doe
John Mr Doe
John m Doe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}