import re
regex = re.compile(r"^[a-zA-Z]{3,40}(?:\s[A-Z])?\s[a-zA-Z]{3,40}$", flags=re.MULTILINE)
test_str = ("John Doe\n"
"John M Doe\n\n"
"John Mr Doe\n"
"John m Doe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")