#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\(?\d{3}\)? {0,2}[-.]? {0,2}\d{3} {0,2}[-.]? {0,2}\d{4}"
Local $sString = "555-555-5555" & @CRLF & _
"(555)555-5555" & @CRLF & _
"(555) 555-5555" & @CRLF & _
"555 -555-5555" & @CRLF & _
"(555)555- 5555" & @CRLF & _
"(555) 555 -5555" & @CRLF & _
"555.555-5555" & @CRLF & _
"555.555.5555" & @CRLF & _
"5555555555" & @CRLF & _
"555-555.5555" & @CRLF & _
"(555)5555555" & @CRLF & _
"(555).555.5555" & @CRLF & _
"(555)-555-5555" & @CRLF & _
"(555555-5555" & @CRLF & _
"555)-555-5555" & @CRLF & _
"555555-5555" & @CRLF & _
"555 5555555" & @CRLF & _
"555 555 5555" & @CRLF & _
"555 - 555 - 5555" & @CRLF & _
"555555 . 5555" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")