import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(?\\d{3}\\)? {0,2}[-.]? {0,2}\\d{3} {0,2}[-.]? {0,2}\\d{4}";
final String string = "555-555-5555\n"
+ "(555)555-5555\n"
+ "(555) 555-5555\n"
+ "555 -555-5555\n"
+ "(555)555- 5555\n"
+ "(555) 555 -5555\n"
+ "555.555-5555\n"
+ "555.555.5555\n"
+ "5555555555\n"
+ "555-555.5555\n"
+ "(555)5555555\n"
+ "(555).555.5555\n"
+ "(555)-555-5555\n"
+ "(555555-5555\n"
+ "555)-555-5555\n"
+ "555555-5555\n"
+ "555 5555555\n"
+ "555 555 5555\n"
+ "555 - 555 - 5555\n"
+ "555555 . 5555\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}