const regex = /(?ms)statusCode: (?<status_code>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)statusCode: (?<status_code>\\d+)', 'gm')
const str = `{ [-]
body: { [-]
message: [ [-]
{ [-]
errorMessage: must have required property 'objectIds'
field: objectIds
}
{ [-]
errorMessage: must be equal to one of the allowed values : [object1,object2]
field: objectType
}
statusCode: 400
type: BAD_REQUEST_ERROR
}
headers: { [-]
Access-Control-Allow-Origin: *
Content-Type: application/json
}
hostname:
level: 50
msg: republish error response
statusCode: 400
time: ****
}
Event 2:500 Error
{ [-]
awsRequestId:
body: { [-]
message: Unexpected token “ in JSON at position 98
}
headers: { [-]
Access-Control-Allow-Origin: *
Content-Type: application/json
}
msg: reprocess error response
statusCode: 500
time: ***
}
Event 3:Success
{ [-]
awsRequestId:
body: { [-]
message: republish request has been submitted for [1] ids
}
headers: { [-]
Access-Control-Allow-Origin: *
Content-Type: application/json
}
}
headers: { [+]
}
msg: republish success response
statusCode: 200
time: ***
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}