# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?ms)statusCode: (?<status_code>\d+)"
test_str = ("{ [-]\n\n"
" body: { [-]\n\n"
" message: [ [-]\n\n"
" { [-]\n\n"
" errorMessage: must have required property 'objectIds'\n\n"
" field: objectIds\n\n"
" }\n\n"
" { [-]\n\n"
" errorMessage: must be equal to one of the allowed values : [object1,object2]\n\n"
" field: objectType\n\n"
" }\n\n"
" statusCode: 400\n\n"
" type: BAD_REQUEST_ERROR\n\n"
" }\n\n"
" headers: { [-]\n\n"
" Access-Control-Allow-Origin: *\n\n"
" Content-Type: application/json\n\n"
" }\n\n"
" hostname: \n\n"
" level: 50\n\n"
" msg: republish error response\n\n"
" statusCode: 400\n\n"
" time: ****\n\n"
"}\n\n"
" \n\n"
"Event 2:500 Error\n\n"
"{ [-]\n\n"
" awsRequestId: \n\n"
" body: { [-]\n\n"
" message: Unexpected token “ in JSON at position 98\n\n"
" }\n\n"
" headers: { [-]\n\n"
" Access-Control-Allow-Origin: *\n\n"
" Content-Type: application/json\n\n"
" }\n\n"
" msg: reprocess error response\n\n"
" statusCode: 500\n\n"
" time: ***\n\n"
"}\n\n"
"Event 3:Success\n\n"
"{ [-]\n\n"
" awsRequestId: \n\n"
" body: { [-]\n\n"
" message: republish request has been submitted for [1] ids\n\n"
" }\n\n"
" headers: { [-]\n\n"
" Access-Control-Allow-Origin: *\n\n"
" Content-Type: application/json\n\n"
" }\n\n"
" }\n\n"
" headers: { [+]\n\n"
" }\n\n"
" msg: republish success response\n\n"
" statusCode: 200\n\n"
" time: ***\n\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.