re = /(?ms)statusCode: (?<status_code>\d+)/m
str = '{ [-]
body: { [-]
message: [ [-]
{ [-]
errorMessage: must have required property \'objectIds\'
field: objectIds
}
{ [-]
errorMessage: must be equal to one of the allowed values : [object1,object2]
field: objectType
}
statusCode: 400
type: BAD_REQUEST_ERROR
}
headers: { [-]
Access-Control-Allow-Origin: *
Content-Type: application/json
}
hostname:
level: 50
msg: republish error response
statusCode: 400
time: ****
}
Event 2:500 Error
{ [-]
awsRequestId:
body: { [-]
message: Unexpected token “ in JSON at position 98
}
headers: { [-]
Access-Control-Allow-Origin: *
Content-Type: application/json
}
msg: reprocess error response
statusCode: 500
time: ***
}
Event 3:Success
{ [-]
awsRequestId:
body: { [-]
message: republish request has been submitted for [1] ids
}
headers: { [-]
Access-Control-Allow-Origin: *
Content-Type: application/json
}
}
headers: { [+]
}
msg: republish success response
statusCode: 200
time: ***
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end