const regex = /^(")(?<name>(.*))(") (<){0,1}(?<email>(?<full>(?<user>.*)@(?<host>(?<subdomain>.*\.)?((?<domain>.*?)\.(?<tld>[^>]+)))))(>?)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(")(?<name>(.*))(") (<){0,1}(?<email>(?<full>(?<user>.*)@(?<host>(?<subdomain>.*\\.)?((?<domain>.*?)\\.(?<tld>[^>]+)))))(>?)$', 'i')
const str = `"Track Admin" hardcodedReplyTo@danieljpostinc.info`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}