$re = '/^(")(?<name>(.*))(") (<){0,1}(?<email>(?<full>(?<user>.*)@(?<host>(?<subdomain>.*\.)?((?<domain>.*?)\.(?<tld>[^>]+)))))(>?)$/i';
$str = '"Track Admin" hardcodedReplyTo@danieljpostinc.info';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);