import Foundation
let pattern = #"^(")(?<name>(.*))(") (<){0,1}(?<email>(?<full>(?<user>.*)@(?<host>(?<subdomain>.*\.)?((?<domain>.*?)\.(?<tld>[^>]+)))))(>?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #""Track Admin" hardcodedReplyTo@danieljpostinc.info"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}