package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\|.+)(\|.+)`)
var str = `High School| Undergraduate| Graduate
---|---|---
1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500
re.findall(r"---\|", "High School| Undergraduate| Graduate ---|---|--- 1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500")`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}