import re
regex = re.compile(r"(\|.+)(\|.+)")
test_str = ("High School| Undergraduate| Graduate \n"
"---|---|---\n"
" 1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500\n\n"
"re.findall(r\"---\\|\", \"High School| Undergraduate| Graduate ---|---|--- 1st Prize: $1,500| 1st Prize: $1,500| 1st Prize: $1,500 2nd Prize: $1,000| 2nd Prize: $1,000| 2nd Prize: $1,000 3rd Prize: $500| 3rd Prize: $500| 3rd Prize: $500\")")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")