const regex = /(\|.+)(\|.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\|.+)(\\|.+)', 'g')
const str = `High School| Undergraduate| Graduate
---|---|---
1st Prize: \$1,500| 1st Prize: \$1,500| 1st Prize: \$1,500 2nd Prize: \$1,000| 2nd Prize: \$1,000| 2nd Prize: \$1,000 3rd Prize: \$500| 3rd Prize: \$500| 3rd Prize: \$500
re.findall(r"---\\|", "High School| Undergraduate| Graduate ---|---|--- 1st Prize: \$1,500| 1st Prize: \$1,500| 1st Prize: \$1,500 2nd Prize: \$1,000| 2nd Prize: \$1,000| 2nd Prize: \$1,000 3rd Prize: \$500| 3rd Prize: \$500| 3rd Prize: \$500")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}