#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<param [^<]+?<\/param>"
Local $sString = "fasfasd fsdaf asdf sdaf asd<param name="Текст">текст</param> f asdfsadf sad fasd" & @CRLF & _
"sd fasdf sdaf asd<param name="Картинки">https://domen.ru</param> dsfasd fsdaf asd" & @CRLF & _
"<param name="Числа">9999</param> sdf as sdf asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")