using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<param [^<]+?<\/param>";
string input = @"fasfasd fsdaf asdf sdaf asd<param name=""Текст"">текст</param> f asdfsadf sad fasd
sd fasdf sdaf asd<param name=""Картинки"">https://domen.ru</param> dsfasd fsdaf asd
<param name=""Числа"">9999</param> sdf as sdf asd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}