// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<param [^<]+?<\/param>").unwrap();
let string = "fasfasd fsdaf asdf sdaf asd<param name=\"Текст\">текст</param> f asdfsadf sad fasd
sd fasdf sdaf asd<param name=\"Картинки\">https://domen.ru</param> dsfasd fsdaf asd
<param name=\"Числа\">9999</param> sdf as sdf asd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}