import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+(?<PHONENUMBER>\\d{8,15})$";
final String string = "+12345678\n"
+ "+1234567\n"
+ "+123456\n"
+ "+12345\n"
+ "+16157725198 \n"
+ "+16157725198\n"
+ "+111111111111111\n"
+ "+1111111111111111\n"
+ "+1111111111111111123123123123123213123\n"
+ "+1(801)8221439\n"
+ "+1(801) 822 1439\n"
+ "+1-801-822-1439";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}