import re
regex = re.compile(r"^\+(?<PHONENUMBER>\d{8,15})$", flags=re.MULTILINE)
test_str = ("+12345678\n"
"+1234567\n"
"+123456\n"
"+12345\n"
"+16157725198 \n"
"+16157725198\n"
"+111111111111111\n"
"+1111111111111111\n"
"+1111111111111111123123123123123213123\n"
"+1(801)8221439\n"
"+1(801) 822 1439\n"
"+1-801-822-1439")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")