#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m) - \d+ : (.+)"
Local $sString = " - 0 : <NSLayoutConstraint:0x6000035b77a0 UILayoutGuide:0x600002fe0e00''.centerY == UIFoundation.TitleSubtitleView:0x7f909a93c110.centerY (active)>" & @CRLF & _
" - 1 : <NSLayoutConstraint:0x6000035b7750 H:|-(0)-[UILayoutGuide:0x600002fe0e00''] (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>" & @CRLF & _
" - 2 : <NSLayoutConstraint:0x6000035b77f0 UILayoutGuide:0x600002fe0e00''.trailing == UIFoundation.TitleSubtitleView:0x7f909a93c110.trailing (active)>" & @CRLF & _
" - 3 : <NSLayoutConstraint:0x6000035b7840 V:|-(>=0)-[UILayoutGuide:0x600002fe0e00''] (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>" & @CRLF & _
" - 4 : <NSLayoutConstraint:0x6000035b7890 V:|-(0@250)-[UILayoutGuide:0x600002fe0e00''] priority:250 (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>" & @CRLF & _
" - 5 : <NSLayoutConstraint:0x6000035b78e0 UILayoutGuide:0x600002fe0ee0''.top == UILayoutGuide:0x600002fe0e00''.top + 12 (active)>" & @CRLF & _
" - 6 : <NSLayoutConstraint:0x6000035b7930 UILayoutGuide:0x600002fe0ee0''.bottom == UILayoutGuide:0x600002fe0e00''.bottom - 12 (active)>" & @CRLF & _
" - 7 : <NSLayoutConstraint:0x6000035b7980 UILayoutGuide:0x600002fe0ee0''.leading == UILayoutGuide:0x600002fe0e00''.leading + 16 (active)>" & @CRLF & _
" - 8 : <NSLayoutConstraint:0x6000035b79d0 UILayoutGuide:0x600002fe0ee0''.trailing == UILayoutGuide:0x600002fe0e00''.trailing - 16 (active)>" & @CRLF & _
" - 9 : <NSLayoutConstraint:0x6000035b7a70 UIFoundation.FadingLabel:0x7f909a9334e0.top == UILayoutGuide:0x600002fe0ee0''.top (active)>" & @CRLF & _
" - 10 : <NSLayoutConstraint:0x6000035b7b10 UIFoundation.FadingLabel:0x7f909a9334e0.leading == UILayoutGuide:0x600002fe0ee0''.leading (active)>" & @CRLF & _
" - 11 : <NSLayoutConstraint:0x6000035b7b60 UIFoundation.FadingLabel:0x7f909a9334e0.trailing == UILayoutGuide:0x600002fe0ee0''.trailing (active)>" & @CRLF & _
" - 12 : <NSLayoutConstraint:0x6000035b7a20 V:[UIFoundation.FadingLabel:0x7f909a9334e0]-(8)-[UIFoundation.FadingLabel:0x7f909a81b610] (active)>" & @CRLF & _
" - 13 : <NSLayoutConstraint:0x6000035b7c00 UIFoundation.FadingLabel:0x7f909a81b610.leading == UILayoutGuide:0x600002fe0ee0''.leading (active)>" & @CRLF & _
" - 14 : <NSLayoutConstraint:0x6000035b7c50 UIFoundation.FadingLabel:0x7f909a81b610.trailing == UILayoutGuide:0x600002fe0ee0''.trailing (active)>" & @CRLF & _
" - 15 : <NSLayoutConstraint:0x6000035b7ca0 UIFoundation.FadingLabel:0x7f909a9334e0.bottom <= UILayoutGuide:0x600002fe0ee0''.bottom (active)>" & @CRLF & _
" - 16 : <NSLayoutConstraint:0x6000035b7ac0 UIFoundation.FadingLabel:0x7f909a9334e0.bottom == UILayoutGuide:0x600002fe0ee0''.bottom (active)>"
Local $sSubst = ""$1","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)