import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " - \\d+ : (.+)";
final String string = " - 0 : <NSLayoutConstraint:0x6000035b77a0 UILayoutGuide:0x600002fe0e00''.centerY == UIFoundation.TitleSubtitleView:0x7f909a93c110.centerY (active)>\n"
+ " - 1 : <NSLayoutConstraint:0x6000035b7750 H:|-(0)-[UILayoutGuide:0x600002fe0e00''] (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>\n"
+ " - 2 : <NSLayoutConstraint:0x6000035b77f0 UILayoutGuide:0x600002fe0e00''.trailing == UIFoundation.TitleSubtitleView:0x7f909a93c110.trailing (active)>\n"
+ " - 3 : <NSLayoutConstraint:0x6000035b7840 V:|-(>=0)-[UILayoutGuide:0x600002fe0e00''] (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>\n"
+ " - 4 : <NSLayoutConstraint:0x6000035b7890 V:|-(0@250)-[UILayoutGuide:0x600002fe0e00''] priority:250 (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>\n"
+ " - 5 : <NSLayoutConstraint:0x6000035b78e0 UILayoutGuide:0x600002fe0ee0''.top == UILayoutGuide:0x600002fe0e00''.top + 12 (active)>\n"
+ " - 6 : <NSLayoutConstraint:0x6000035b7930 UILayoutGuide:0x600002fe0ee0''.bottom == UILayoutGuide:0x600002fe0e00''.bottom - 12 (active)>\n"
+ " - 7 : <NSLayoutConstraint:0x6000035b7980 UILayoutGuide:0x600002fe0ee0''.leading == UILayoutGuide:0x600002fe0e00''.leading + 16 (active)>\n"
+ " - 8 : <NSLayoutConstraint:0x6000035b79d0 UILayoutGuide:0x600002fe0ee0''.trailing == UILayoutGuide:0x600002fe0e00''.trailing - 16 (active)>\n"
+ " - 9 : <NSLayoutConstraint:0x6000035b7a70 UIFoundation.FadingLabel:0x7f909a9334e0.top == UILayoutGuide:0x600002fe0ee0''.top (active)>\n"
+ " - 10 : <NSLayoutConstraint:0x6000035b7b10 UIFoundation.FadingLabel:0x7f909a9334e0.leading == UILayoutGuide:0x600002fe0ee0''.leading (active)>\n"
+ " - 11 : <NSLayoutConstraint:0x6000035b7b60 UIFoundation.FadingLabel:0x7f909a9334e0.trailing == UILayoutGuide:0x600002fe0ee0''.trailing (active)>\n"
+ " - 12 : <NSLayoutConstraint:0x6000035b7a20 V:[UIFoundation.FadingLabel:0x7f909a9334e0]-(8)-[UIFoundation.FadingLabel:0x7f909a81b610] (active)>\n"
+ " - 13 : <NSLayoutConstraint:0x6000035b7c00 UIFoundation.FadingLabel:0x7f909a81b610.leading == UILayoutGuide:0x600002fe0ee0''.leading (active)>\n"
+ " - 14 : <NSLayoutConstraint:0x6000035b7c50 UIFoundation.FadingLabel:0x7f909a81b610.trailing == UILayoutGuide:0x600002fe0ee0''.trailing (active)>\n"
+ " - 15 : <NSLayoutConstraint:0x6000035b7ca0 UIFoundation.FadingLabel:0x7f909a9334e0.bottom <= UILayoutGuide:0x600002fe0ee0''.bottom (active)>\n"
+ " - 16 : <NSLayoutConstraint:0x6000035b7ac0 UIFoundation.FadingLabel:0x7f909a9334e0.bottom == UILayoutGuide:0x600002fe0ee0''.bottom (active)>";
final String subst = "\"$1\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}