// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m) - \d+ : (.+)").unwrap();
let string = " - 0 : <NSLayoutConstraint:0x6000035b77a0 UILayoutGuide:0x600002fe0e00''.centerY == UIFoundation.TitleSubtitleView:0x7f909a93c110.centerY (active)>
- 1 : <NSLayoutConstraint:0x6000035b7750 H:|-(0)-[UILayoutGuide:0x600002fe0e00''] (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>
- 2 : <NSLayoutConstraint:0x6000035b77f0 UILayoutGuide:0x600002fe0e00''.trailing == UIFoundation.TitleSubtitleView:0x7f909a93c110.trailing (active)>
- 3 : <NSLayoutConstraint:0x6000035b7840 V:|-(>=0)-[UILayoutGuide:0x600002fe0e00''] (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>
- 4 : <NSLayoutConstraint:0x6000035b7890 V:|-(0@250)-[UILayoutGuide:0x600002fe0e00''] priority:250 (active, names: '|':UIFoundation.TitleSubtitleView:0x7f909a93c110 )>
- 5 : <NSLayoutConstraint:0x6000035b78e0 UILayoutGuide:0x600002fe0ee0''.top == UILayoutGuide:0x600002fe0e00''.top + 12 (active)>
- 6 : <NSLayoutConstraint:0x6000035b7930 UILayoutGuide:0x600002fe0ee0''.bottom == UILayoutGuide:0x600002fe0e00''.bottom - 12 (active)>
- 7 : <NSLayoutConstraint:0x6000035b7980 UILayoutGuide:0x600002fe0ee0''.leading == UILayoutGuide:0x600002fe0e00''.leading + 16 (active)>
- 8 : <NSLayoutConstraint:0x6000035b79d0 UILayoutGuide:0x600002fe0ee0''.trailing == UILayoutGuide:0x600002fe0e00''.trailing - 16 (active)>
- 9 : <NSLayoutConstraint:0x6000035b7a70 UIFoundation.FadingLabel:0x7f909a9334e0.top == UILayoutGuide:0x600002fe0ee0''.top (active)>
- 10 : <NSLayoutConstraint:0x6000035b7b10 UIFoundation.FadingLabel:0x7f909a9334e0.leading == UILayoutGuide:0x600002fe0ee0''.leading (active)>
- 11 : <NSLayoutConstraint:0x6000035b7b60 UIFoundation.FadingLabel:0x7f909a9334e0.trailing == UILayoutGuide:0x600002fe0ee0''.trailing (active)>
- 12 : <NSLayoutConstraint:0x6000035b7a20 V:[UIFoundation.FadingLabel:0x7f909a9334e0]-(8)-[UIFoundation.FadingLabel:0x7f909a81b610] (active)>
- 13 : <NSLayoutConstraint:0x6000035b7c00 UIFoundation.FadingLabel:0x7f909a81b610.leading == UILayoutGuide:0x600002fe0ee0''.leading (active)>
- 14 : <NSLayoutConstraint:0x6000035b7c50 UIFoundation.FadingLabel:0x7f909a81b610.trailing == UILayoutGuide:0x600002fe0ee0''.trailing (active)>
- 15 : <NSLayoutConstraint:0x6000035b7ca0 UIFoundation.FadingLabel:0x7f909a9334e0.bottom <= UILayoutGuide:0x600002fe0ee0''.bottom (active)>
- 16 : <NSLayoutConstraint:0x6000035b7ac0 UIFoundation.FadingLabel:0x7f909a9334e0.bottom == UILayoutGuide:0x600002fe0ee0''.bottom (active)>";
let substitution = "\"$1\",";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}