#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{0,5}u)(?=.{0,5}e)(?=.{0,5}a)(?=.{0,5}p)(?=.{0,5}s)[^trckfildjm][^utrckfildjm][^aetrckfildjm][^ptrckfildjm][^strckfildjm]$"
Local $sString = "pause" & @CRLF & _
"puuse" & @CRLF & _
"tause" & @CRLF & _
"gabby" & @CRLF & _
"gabon"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")