re = /^(?=.{0,5}u)(?=.{0,5}e)(?=.{0,5}a)(?=.{0,5}p)(?=.{0,5}s)[^trckfildjm][^utrckfildjm][^aetrckfildjm][^ptrckfildjm][^strckfildjm]$/m
str = 'pause
puuse
tause
gabby
gabon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end