import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{0,5}u)(?=.{0,5}e)(?=.{0,5}a)(?=.{0,5}p)(?=.{0,5}s)[^trckfildjm][^utrckfildjm][^aetrckfildjm][^ptrckfildjm][^strckfildjm]$";
final String string = "pause\n"
+ "puuse\n"
+ "tause\n"
+ "gabby\n"
+ "gabon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}