#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+"
Local $sString = "Tsuru Stork greeting for a long last life. Unisex" & @CRLF & _
"Yama Mountain; Restrainer; Unisex " & @CRLF & _
"Yuka A bright Star Unisex " & @CRLF & _
"Yumi A beautiful archery bow Unisex " & @CRLF & _
"Yuna The archer Unisex"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")